4g61t.org

Specializing in the 3g CSM
It is currently Sun Mar 24, 2019 1:40 am

All times are UTC-05:00




Post new topic  Reply to topic  [ 76 posts ]  Go to page 1 2 3 4 5 6 Next
Author Message
PostPosted: Sat Jul 25, 2015 11:23 pm 
Offline
Some call me a god
User avatar

Joined: Sat Jul 07, 2007 10:40 pm
Posts: 1012
Location: Stuarts Draft,VA
Well I have been wanting one of these for so long now and I have been holding off for a AWD model preferably auto. At last one has pretty much fell into my lap and I will be picking it up this Monday. I went and looked at it the other night and the body and underside is very straight and rust free! The only down side is the car seems to have been parked under a tree and is very dirty on the outside and the interior looks like a animal (no joke) may have been in it. The interior is filthy but the seats and dash aren't torn just stained which is weird to me. I couldn't find any noticeable dents other than a few on the hood.

I plan on getting the car which runs excellent at 174k up to par with it's new daily driver duties ahead. Iv'e been driving my Galant way too much and wanna start tearing the underside out to completely recondition and undercoat it. I can't wait to put my 92 gvr4 wheels back to use and put them on. The Nile black wheels should work well with the two tone white and black van.


Last edited by UnderPSI on Tue Aug 11, 2015 8:46 am, edited 3 times in total.

Top
   
PostPosted: Sat Jul 25, 2015 11:27 pm 
Offline
Moderator
User avatar

Joined: Wed Jan 04, 2006 1:21 pm
Posts: 2105
Location: Tucson Az
very nice.. ive been searching for one also but I want a white 92 only..auto awd.. so needless to say my hunt will take alot longer lol.... gratz on the new ride..



Steve

_________________
Steve 89 colt 2.3 stroker stock top end. evo3@20 psi 13.489@99.30mph 3/10 2012
On drag radials.auto trans.launching @ 5 psi and no traction thru 2nd.


Top
   
PostPosted: Sun Jul 26, 2015 1:05 am 
Offline
Moderator

Joined: Sat May 14, 2005 11:15 pm
Posts: 7510
Location: Stantonsburg, NC
Very nice! I have a full set of mudflaps and a tach cluster if yours doesn't have one already.

_________________
95 Eagle Summit DL coupe
15 Mitsubishi Mirage ES hatch


Top
   
PostPosted: Sun Jul 26, 2015 10:24 am 
Offline
Some call me a god
User avatar

Joined: Sat Jul 07, 2007 10:40 pm
Posts: 1012
Location: Stuarts Draft,VA
Quote:
Very nice! I have a full set of mudflaps and a tach cluster if yours doesn't have one already.
I'l probably get the mud flaps soon, and I was happy to see it does have a tach. :)


Top
   
PostPosted: Sun Jul 26, 2015 11:44 am 
Offline
CSM Junkie

Joined: Sat Dec 20, 2008 7:45 am
Posts: 503
Location: tampa
welcome aboard. super fun car. really enjoying fixing up mine.


Top
   
PostPosted: Sun Jul 26, 2015 3:11 pm 
Offline
Some call me a god
User avatar

Joined: Sat Jul 07, 2007 10:40 pm
Posts: 1012
Location: Stuarts Draft,VA
Update: I stopped by and looked at it in the sunlight today, it has two small pieces of rust starting that will get taking care of asap. I also goofed on the year and the car is in fact a 93 not a 94. I took some better pics that I will upload later.


Top
   
PostPosted: Sun Jul 26, 2015 3:50 pm 
Offline
Moderator

Joined: Sat May 14, 2005 11:15 pm
Posts: 7510
Location: Stantonsburg, NC
The GVR4 wheels will look great on there. I remember the one on here, the guy lived down in Texas. Same color as this one with gray GVR4 wheels, looked like they should have came on it from the factory.

_________________
95 Eagle Summit DL coupe
15 Mitsubishi Mirage ES hatch


Top
   
PostPosted: Sun Jul 26, 2015 11:43 pm 
Offline
CSM Junkie

Joined: Sat Dec 20, 2008 7:45 am
Posts: 503
Location: tampa
hey look its got the elusive 5lb. tailgate wing!


Top
   
PostPosted: Mon Jul 27, 2015 7:05 am 
Offline
CSM Junkie
User avatar

Joined: Sat Sep 22, 2012 6:40 pm
Posts: 667
Location: Indianapolis, IN
Pics are broke

_________________
Thom
1991 GVR4 1025/2000 (PTE 1200's, 16g, DSMLink v3, gm-maf, eagle/ross, .020 over, 272's, EVO VIII Wheels)
1992 GVR4 866/1000 (getting everything from above)


Top
   
PostPosted: Mon Jul 27, 2015 10:56 pm 
Offline
Some call me a god
User avatar

Joined: Sat Jul 07, 2007 10:40 pm
Posts: 1012
Location: Stuarts Draft,VA
Quote:
Pics are broke
I accidentally deleted the folder they were in. :rolleyes: I'll get better pics tomorrow morning. I also found out the car is a 1.8 and not a 2.4, that's kind of a bummer. I guess that gives me some incentive to swap it in the future, but I have to get some guidance on the parts needed and such. I have a mint 1g harness and ecu with ecmlink v2.5 laying around and would rather go that route for simplicity sake.

Image

Image

Image

little surface rust here
Image

Image

worst of the rust on the whole car, about the size of a dime
Image

heavy wing, lol
Image

needs a bath/detail bad.
Image

It's gonna ease the dd pain of #740
Image


Top
   
PostPosted: Mon Jul 27, 2015 11:57 pm 
Offline
CSM Junkie

Joined: Sat Dec 20, 2008 7:45 am
Posts: 503
Location: tampa
wow. nice one. very solid. no rust at all. less rust than mine, and I consider mine a rust free car. mine had all that black mold on the car as well.

are you not planning a turbo swap on the car? the 1.8 shouldnt be a disappointment. its nearly as powerful as the 2.4, but gets great mileage.


Top
   
PostPosted: Tue Jul 28, 2015 12:10 am 
Offline
Some call me a god
User avatar

Joined: Sat Jul 07, 2007 10:40 pm
Posts: 1012
Location: Stuarts Draft,VA
Quote:
wow. nice one. very solid. no rust at all. less rust than mine, and I consider mine a rust free car. mine had all that black mold on the car as well.

are you not planning a turbo swap on the car? the 1.8 shouldnt be a disappointment. its nearly as powerful as the 2.4, but gets great mileage.
A swap is in the plan for the future, right now I'm gonna focus on getting the 4g93 reliable.


Top
   
PostPosted: Tue Jul 28, 2015 3:06 pm 
Offline
Some call me a god
User avatar

Joined: Sat Jul 07, 2007 10:40 pm
Posts: 1012
Location: Stuarts Draft,VA
Took a couple better pics today.

other than the rocker rust here is a tiny bit on the inner fender.

Image

a few underbody pics
Image

Image

Image

Image

Image

The interior plastics are shot. :o
Image

Image

Maybe they hauled goats in it? :rolleyes:
Image

Broken arm rest
Image

I have my work cut out for me with these seats.
Image

Image

Image

Guy says it has a fuel leak, hmmm I wonder why.
Image

Image

Image

Image

Image

Image


Top
   
PostPosted: Tue Jul 28, 2015 3:12 pm 
Offline
Moderator

Joined: Sat May 14, 2005 11:15 pm
Posts: 7510
Location: Stantonsburg, NC
Awesome, with a little TLC she'll be good as new in no time.

_________________
95 Eagle Summit DL coupe
15 Mitsubishi Mirage ES hatch


Top
   
PostPosted: Fri Jul 31, 2015 7:36 pm 
Offline
Some call me a god
User avatar

Joined: Sat Jul 07, 2007 10:40 pm
Posts: 1012
Location: Stuarts Draft,VA
Needless to say I quickly removed the old carpet because it is completely shot and had a few tears by the drivers feet. Then uh oh, I had a sneaky suspicion about the drivers side floor when I felt that the padding under the carpet was damp. There is a hole on the underside of the car, I have no clue how I missed it. Water must have gathered inside the car somehow (guessing windshield) and come to rest just above the hole. The rust isn't all the way through though which has me confused, I can put my hand in the hole and there is another layer of steel separating the inside from the out? As far as I can tell it is not structural but a boxed area?

I am going to grind out as much as I can in the next few days along with the other tiny spots on the body. Seems like I should be able to cut out a clean piece from a donor and patch it, but we'll see what my friend has to say about it.

I also am having a problem with load/revving the engine up quickly. The motor will bog down with the throttle pressed quickly and stall if I don't let out. It will rev up easy if I apply the gas slowly and kind of clears up after 3k rpm. I did replace the ghetto filter and clamp with the right fuel line and new filter and it still did it. Yesterday I found that the regulator was stuck and wouldn't allow fuel to bleed off so I swapped it out with a 2g turbo regulator(not sure about pressure difference) I had lying around. Today I cleaned out the injectors one by one with pressure and cycling fuel injector cleaner through each one. This seemed to help and it is actually drivable now but will still stumble upon quick acceleration. I also reset the base timing and I guess the next things on the list are plugs, plug wires, and distributor cap and rotor. Could it possibly be the fuel pump strainer clogged? The pump sounds smooth to me and no whining.

One good thing that came out of the day was that it looks ten times better with the 92 gvr4 wheels on it. Pics to come


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 76 posts ]  Go to page 1 2 3 4 5 6 Next

All times are UTC-05:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited